Coming soon!

xbuild and “the PCL reference assemblies not installed” error message

I was trying to setup a build script with FAKE to build a Xamarin solution via a bash script which I could then use in TeamCity. In Xamarin Studio I could build my solution without any errors but when trying to run my script in a terminal, I received this error: “PCL reference assemblies not… Continue reading xbuild and “the PCL reference assemblies not installed” error message

  • CI

By Thomas Van den Bossche · 7/6/2015 6:54:02 PM (Original Post)

I was trying to setup a build script with FAKE to build a Xamarin solution via a bash script which I could then use in TeamCity.
In Xamarin Studio I could build my solution without any errors but when trying to run my script in a terminal, I received this error: “PCL reference assemblies not installed”.

I searched for several solutions untill I uninstalled Xamarin and Mono.
When reinstalling Xamarin I suddenly noticed that it was installing Mono version 4.0.2.

The error message, however, showed version 4.0.1.

After noticing this difference, I remembered I installed Mono via Homebrew to run ASP.NET vNext on Mac OS X.
After uninstalling it with

brew uninstall mono

, my script runned without any errors.

Sigh…


  • CI

By Thomas Van den Bossche · 7/6/2015 6:54:02 PM (Original Post)

Share this blogpost

Looking for talent?

Fill in the form below and we’ll get back to you as soon as possible.

Oops. You seem to have written your full name in invisible ink. Please enter it so we can read it. Oops. You seem to have written your company in invisible ink. Please enter it so we can read it. It seems your e-mail doesn’t exist. Please enter a real one so we can contact you. Oops. You seem to have written your telephone in invisible ink. Please enter it so we can read it.